Author Topic: Running Ubuntu 18.04 under Windows 10 with HyperV - Resolution Solved  (Read 74 times)

0 Members and 1 Guest are viewing this topic.

rsutter

  • Administrator
  • Hero Member
  • *****
  • Posts: 118
  • I cut the board twice and it's still too short.
    • View Profile
Hello All,
My main laptop computer is a Lenovo Yoga X1, a high-end machine running at 2560x1440 dpi.  However, when I enabled HyperV under Windows 10 and installed Linux Ubuntu 18.04,
Ubuntu only filled about 1/4 of the screen.  From past experience, I knew that I would have to edit the grub file in order to achieve a higher resolution.
For the record, here are the steps to accomplish that
From Ubuntu, open the Terminal to the default directory.  Here is how I did that
At the terminal, change to the root directory by typing cd /
Type cd /etc
Type cd default (Notice that the command was not cd /default
Type sudo gedit grub (This sequence opens the Gedit text editor to the grub file at /etc/default)
Enter your password (It will not be displayed)

The grub file contains a line that reads as follows
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
Modify it to read as follows
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=hyperv_fb:1920x1080"
Save the file
Type update-grub to do just that

IMPORTANT
Return to the Windows desktop and change the screen resolution in Windows to 1920x1080. 
Do this by going to the desktop and right clicking an open area.
Left click on Display Settings and change to 1920x1080

Re-launch Ubuntu and it will fill the screen.  If you skip the previous step, the Ubuntu desktop will not cover the Windows desktop completely. 
The native resolution of my laptop is 2560x1440 but at the time of this posting, Ubuntu is apparently only capable of delivering 1920x1080.  Entering a higher resolution in grub fails.

Ralph Sutter
« Last Edit: August 17, 2018, 09:33:54 AM by rsutter »